Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion


Can minimo be programmed with an FTDI?


  • edited April 2019

    I haven't done it, but it should be possible, for as long as what you want to do is send new programs to an already "working" miniMO. If you want to build and program a miniMO from scratch, you'll have to set the fuses in the microcontroller first with an AVR programmer (I use an Arduino-as-ISP).

  • i spent all last evening trying to get the arduinoasISP thing to work on one of my minimos- i just get the "Yikes invalid device signature" 00000, etc." is there info on how to set the fuses?

  • Quick question -programming issues aside, is that miniMO working fine?
    Also, can you post a picture showing how you're connecting the miniMO to the arduino?

  • no, it was running the DCO sketch just fine, but & now it doesnt make any noise. i tried it with 2 unos with your shared headers trick and a mega

  • edited April 2019

    but only the sequencer sketch :(

  • edited April 2019

    Some programs work with recent versions of the IDE, but most don't. Take a look at the post right before this one for an explanation :). Now, if you could flash a program in 1.8.9, you should be able to flash any program in 1.5.7. Can you try flashing the luna mod generator from 1.5.7, for instance?

    -Also... shared headers? can you clarify?

  • that's right. only my 'good' one flashes. the other is still dead. "shared headers" = like in your programming instruction page. could i have 'burned the bootloader' on it, which would have reset the fuses?

  • edited April 2019

    Ah, I see.
    I'm trying to troubleshoot, but I still don't have a clear picture of what happened, so bear with me :)

    Let's confirm: you have a MO that a.suddenly stopped working, or b.stopped working after you tried to program it?

    Also, is it completely dead or does it at least light up?

    (It is possible to sort of brick the processor if you burn the bootloader and had an option selected that set the ATtiny to work with an external clock. With a regular miniMO you don't need to do this to start with, though, and it's not something that would happen by accident).

  • B. i think thats exactly what i did lol. "BurnBootloader" is right under "Programmer". LED is dead too.

  • Ok, then I think you might have actually bricked it. :'(

    If you had an "external clock" option selected when you burned the bootloader, now the processor won't work at all on its own.
    Since the processor is not dead but misconfigured, it should still be possible to reprogram it with a high voltage programmer, but I've never tried doing this myself. If you want to do some research, look for "ATtiny 12v programming", and you should get plenty of information on these programmers.

  • ok - i'll explore that & report back!

  • nice -please write back if you give any of them a try :)

  • edited July 2019

    Ok I fixed it. stop the clock! how long did that take :) it just took a new chip + USBASP programmer & some creative soldering

  • edited July 2019

    awesome! back on track :smiley:

Sign In or Register to comment.